Заказать обратный звонок:



Урок№3 Последнее задание из ДЗ

Верный старт в 1C / Урок№3 Последнее задание из ДЗ

В этой теме 1 ответ, 2 участника, последнее обновление  Харитонов Дмитрий 3 нед., 3 дн. назад.

Просмотр 2 сообщений - с 1 по 2 (из 2 всего)
  • Автор
    Сообщения
  • #3723

    wano55rus
    Участник

    Здравствуйте, писал вопрос в другой ветке но там он так и не отобразился. Суть вопроса, в последнем задании «Изменить цену для конкретного товара во всех документах установка цен номенклатуры — установить 5000. » создал обработку, на форме создал реквизит для ввода номенклатуры которую хочу изменять, в модуле прописал ее точно так же как и период, но выходит вот такая ошибка «{Обработка.о1.Форма.Форма.Форма(4)}: Ошибка при вызове метода контекста (Выбрать)
    Выборка=Документы.УстановкаЦенНоменклатуры.Выбрать(,ВыборНоменклатуры);по причине:
    Несоответствие типов (параметр номер ‘2’), подскажите в чем моя ошибка?? Базу прилагаю: https://yadi.sk/d/F8blj6Yt3WJTyu
    Код в модуле:
    &НаСервере
    Процедура СнятьПроведениеНаСервере()
    Выборка=Документы.УстановкаЦенНоменклатуры.Выбрать(,ВыборНоменклатуры);
    Пока Выборка.Следующий()Цикл
    Объект1=Выборка.ПолучитьОбъект();
    Для Каждого ТекСтр Из Объект1.Данные Цикл
    ТекСтр.Цена=5000;
    КонецЦикла;
    Объект1.Записать(РежимЗаписиДокумента.ОтменаПроведения);
    КонецЦикла;

    КонецПроцедуры

    &НаКлиенте
    Процедура СнятьПроведение(Команда)
    СнятьПроведениеНаСервере();
    КонецПроцедуры

    #3748

    Документы.УстановкаЦенНоменклатуры.Выбрать(,ВыборНоменклатуры) — перепишите код как
    Документы.УстановкаЦенНоменклатуры.Выбрать()

    В цикле Для Каждого ТекСтр Из Объект1.Данные Цикл надо сделать проверку на равенство номенклатуры в текущей строке номенклатуре выбранной на форме
    Если ТекСтр.Номенклатура = ВыборНоменклатура Тогда ….. Установить цену 5000

Просмотр 2 сообщений - с 1 по 2 (из 2 всего)

Для ответа в этой теме необходимо авторизоваться.